FileBlog Ver.2.3以降で、ファイルのダウンロード・フォルダのダウンロードに失敗するときは、下記を確認してください

症状

Microsoft Internet Explorer をお使いの環境で、ファイルやフォルダをダウンロードしようとすると、下記のような画面が出てダウンロードが出来ない。(FileBlog Ver.2.3.0.63以降では、インターネットゾーンでファイルのダウンロードが可能になりました。ただし、フォルダのダウンロードなど一部の機能では、なおも本ページ記載の設定が必要です。)

原因

FileBlog Ver.2.3以降ではスクリプトを用いてファイルのダウンロードを行いますが、IEのセキュリティ設定では、通常、未知のサイト(インターネットゾーン)のサイトからのダウンロードがブロックされる(IEによって妨げられる)ためです。

対処方法

まず、インターネット・エクスプローラ(IE)の画面右下のステータスバーに「インターネットゾーン」と表示されていないかを確認してください。

IEは、接続先のサイトを「ゾーン」に分類し、それに応じたセキュリティを適応します。通常は下記の3つを使います。

  • 「ローカル・イントラネット」ゾーンは、社内ネットワークのゾーンで、最もゆるいセキュリティ
  • 「インターネット」ゾーンは、未知のサイトのゾーンで、最も厳しいセキュリティ
  • 「信頼済サイト」ゾーンは、その中間で、ローカル・イントラネットに近いセキュリティ

※ 4番目として「制限付きサイト」がありますが、アクセスを制限・禁止されてしまいます。

FileBlogのURLにアクセスして「インターネットゾーン」が表示されていた場合には、下記の手順でFileBlogサーバを「信頼済サイト」に追加します。

メニューから「インターネットオプション」を選択します。

IE6/IE8の場合、メニューの「ツール」から選択できます。IE7の場合は、かわりにボタンを押します


セキュリティタブを開き、「信頼済サイト」をクリックして「サイト」ボタンを押します。(なお、社内ネットワークでの運用の場合には代わりに「ローカル・イントラネット」ゾーンを選択して下さい)

FileBlogサーバのアドレスを、「追加」ボタンを押してリストに追加します。イントラネットでの運用で、httpアクセスの場合には、「このゾーンのサイトにはすべてサーバの確認を必要とする」のチェックを外してください。

通常は、上記設定により、FileBlogアクセスは「信頼済サイト」(または「ローカル・イントラネット」)ゾーンとみなされ、ファイルのダウンロードが可能になります。なお、信頼済サイトのセキュリティレベルがカスタマイズされていると、なお失敗することもあります。その場合は、レベルのカスタマイズにて、下記を変更してください。

  • ダウンロード:ファイルのダウンロード=有効にする
  • ダウンロード:ファイルのダウンロード時に自動的にダイアログを表示=有効にする

※ Windows XPのデフォルトでは、イントラネットゾーンおよび信頼済サイトで、上記2つが許可されています。